[Enigmail] Dropped Support for GnuPG 1.4.x in Nightly Builds

Philip Jackson philip.jackson at nordnet.fr
Thu Mar 19 21:12:39 CET 2015


On 19/03/15 18:36, Patrick Brunschwig wrote:
> I pushed a number of changes that remove support for GnuPG 1.x from
> Enigmail. The main objective was to remove anything concerning
> passphrase handling from Enigmail, as GnuPG 2.x does this by itself.
> 
> Given the many places I had to touch in the code, I wanted to do this
> as early as possible, such that we can test if this works OK for the
> whole cycle of 1.9 nightlies.
> 
It certainly doesn't like gnupg 1.4.16 !!  I lost track of the number of warning
dialogs it gave me and I had to restart Thunderbird to get enigmail back.

It also failed to send this message signed with enigmail alert

"Error - encryption command failed"

Philip





More information about the enigmail-users mailing list